Streaming live at 10am (PST)

1. Problem with minified HTML 2. Downloaded Page looks different

Hello Community,

this is my first post, so be gentle.

I have two problems, the first problem is that even if I disable the minified HTML in the hosting settings in minifies the HTML upon export. I’ve seen this problem was discussed in the forum, but I couldn’t find a topic with a solution to this problem. If I simply haven’t found it, please redirect me.

The second problem is possibly related to this issue, at least that’s my guess. The downloaded page looks different from what the online page looks like.

This is the online page: https://maxine-hargrove-portfolio.webflow.io/

I will add screenshots of the downloaded version but these are the differences I noticed:

  1. The grey background behind the form is expanded in height
  2. Every part of the page where I used the grid is messed up. It shows space enough for 4 columns but only fills columns 2 and 4 with content. Columns 1 and 3 are empty.
  3. Everywhere where I used 3 columns the third column has some weird spacing at the top.

I have the feeling this could be caused by a messed up minified HTML which is why I am desperate to solve the minify problem.

Thank you very much for your help!

What browser are you using to view the exported site?

@neotenist - I tested on FF (mac + win), Chrome (mac + win), Safari (mac and could not duplicate your issues.

Try clearing your browser cache.

I don’t think you can recreate the problem if you don’t have the downloaded file. I’ve tried it on several browsers and computers. Mac and Windwos, the issue is definitely there.

Oh and I duplicated the page on my dashboard and the problems are there also.
This is the duplicate: https://talendu.webflow.io/
This is the original: https://maxine-hargrove-portfolio.webflow.io/

Ok, I gave https://maxine-hargrove-portfolio.webflow.io/ a new name and then reverted it back to the original, now it looks the same as the downloaded version.

It still looks like it is supposed to though in the Designer.

What is going on???

Hi @neotenist, thanks for the post.

There is an open bug that our team is working to get fixed that affects to a small number of projects where whitespace gets introduced to the export. I do not yet have a timeline for when new updates will be pushed out yet.

One workaround when exporting is to minify the html on export, which strips away the extra whitespace automatically.

If you press ctrl+o on the keyboard, this will open the advance export option which allows you to export the code minified as it is on the published webflow.io site.

You might also need to first use an external tool like Will Peavy’s minifier to first minify and then unminify the code: https://www.willpeavy.com/tools/minifier/

Could you try the minification and export, then check and see if that helps make things look normal after export?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.