Streaming live at 10am (PST)

1px bug on animation move

Hi

I have a “1px bug” when I try to animate this block of 10 images.

On load : no problem
On hover on : the blue or orange masks don’t match anymore with the background image and the parent (around 1px)
On hover out : the blue and orange masks don’t return properly (1px around)

On Retina displays (with Safari, I have tested with my MacBook Pro and Ipad) this effect is minimal.

But with my MacPro and on Eizo 27 monitor, this effect is real and I can’t sell that to a client.

Hier an image :

The website is here : http://schelling-dr.webflow.io/team-und-praxis

user: preview
Password: okidoc

Thank you for your help


Here is my public share link: LINK
(how to access public share link)

Please ensure that there is no zoom in your browser. Press CTRL + 0 to reset the zoom to 100%.

Hi,

The zoom level is ok with all browsers I have tested.

The problem disappears when the animations are deactivated. That’s why I think this is more linked with a blur or a webkit problem.

@+ Fred

What about removing the perspective on .combo-timeline?

Hi, thank you Samliew

Your solution doesn’t work. I had the perspective parameters integrated as a solution for my problem but…

@+ Fred

Hi,

The problem seems to be linked with the “overflow: hidden” parameter set on the parent element.

I can’t find a solution. Any idea?

Fred

This seems to be a problem for 4k screens + Safari. I am unable to repro it on Google Chrome Windows 10, with a 4k monitor.

Hi Samliew,

Thank you for your help.

I always work in Webdesign with several devices (smartphones, tablets, laptops and so on, Mac and PC systems, all main browsers in game).

I can reproduce the problem (1px linked with overflow: hidden parameter) with all devices I have and all browsers, 4k, HDPI and normal screens, Mac and PC. Ok! It’s not a catastrophe. But I found this not good enough for my quality management.

I have to found another way to accomplish this.

Thank you for your time.

Fred, Germany

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.