Streaming live at 10am (PST)

301 Redirect Chains - HTTPS to HTTP to HTTPS

On my Webflow site I have a 301 Redirect chain happening which goes from https to http and then back to https. As a result of which it is impacting all SEO audits and checks. Is there a way to clean up or delete the 301 redirects happening.

My site was originally on WordPress and has been created new on Webflow 3 months back.


Here is my site Read-Only: https://preview.webflow.com/preview/podcastinc?utm_medium=preview_link&utm_source=designer&utm_content=podcastinc&preview=579cd87a7b202239a6c313ea290d9e22&mode=preview

I am experiencing the same problem with my sites.
@WebflowCommunityTeam is there a solution for this problem?

Go to Site Settings > Hosting tab. Add the path to the old file URL and then choose which page in your site users should be re-directed to. I hope it will help.

unfortunately this is not the problem.
There are no redirections set.

main domain is set to www.
when going to https://domain.tld is is routed to http://www.domain.tld and then to https://www.domain.tld

from https to http to https

this behaviour is with mutliple domains from various providers.

I have the same problem.
It is related to the “Default” domain at the Custom Domain settings.
We have www.domain.tld as default. When you select https://domain.tld in the browser you are redirected to http://www.domain.tld and then to https://www.domain.tld.

I tried switching the default, but then the same problem occurs with http://domain.tld.

The result is that the site doesn’t work in iframes on a https site
Mixed Content: The page at ‘…’ was loaded over HTTPS, but requested an insecure frame ‘http://www…’.
This request has been blocked; the content must be served over HTTPS.

Also the site doesn’t work on browsers that insist on https only.

It is probably a configuration issue in the reverse proxy openresty / varnish / nxing
Because in the chrome dev console you can see the following response headers:
accept-ranges: bytes
accept-ranges: bytes
accept-ranges: bytes
accept-ranges: bytes
age: 0
age: 0
content-length: 166
content-type: text/html
date: Tue, 08 Sep 2020 15:55:50 GMT
location: http://www
server: openresty
status: 301
via: 1.1 varnish
via: 1.1 varnish
x-cache: MISS, MISS
x-cache-hits: 0, 0
x-cluster-name: eu-west-1-prod-eks-15
x-served-by: cache-dca17730-DCA, cache-dub4321-DUB
x-timer: S1599580550.070954,VS0,VE142

This is a major issue. Google is de-ranking sites so this is a major SEO cluster-F

*911!

Big problem. Same here on 3 sites.

Same on couple of hosted sites. Where’s @webflow?

Webflow has some new A records shown in project settings. Try using them.

@webdev That’s what the Support told me but it killed my sites completely. Its now tototaly lost in redirections and the browsers are stopping connecting with my site.
No Idea what to do now…

[edit] just when I hit the send button I realized the old trick setting www as default domain, which brought my site back online. seem to be working now!

i have this problem and what is the solution?

can you help me how you did?

Changing the DNS setting to the new ones and setting the www as default Domain helped solving the issue.

As webflow announced today here:

1 Like

we fixed it thanks!it works now.

what about non-www as default domain? still no solution? A records and new IPs are for www default domains only.