Streaming live at 10am (PST)

404 error - imported link displays correctly on collection page but goes to Webflow url

Hello, I am trying to import a list from a csv file (1300 items) into a dynamic collection. The import works fine for all field types except link. On the collection page, the url for the link field is displaying correctly (eg. www.example.com) but when I hover over the link the url shows as (https://webflow.com/design/example.com). So I get a 404 error pointing to the Webflow site. For simplicity I’ve reduced the collection to 68 items, it’s called Burnside Businesses with a corresponding collection page Burnside Businesses.

Here is my read-only link https://preview.webflow.com/preview/leeannes-amazing-project?utm_medium=preview_link&utm_source=dashboard&utm_content=leeannes-amazing-project&preview=f007e72fc5aac096ccd96d947f2f1950&mode=preview

Please help I am at wit’s end and on deadline! Thank you.

This is a strange incident.
I can’t modify the CMS, but I was thinking to add the https://
Also, does this occur on the published site?

Ah yes, you are correct! When I manually add http:// to the link it works perfectly! Thank you.
Problem now is I have 1300 items, do you know of a way to add http:// to each link without doing it manually?

Glad it worked!
I would go back to the csv, correct there, then import again. Sorry, that’s all I can think of. At least in the csv you can do a remove (www.) and replace with (http://www.) so only a few clicks.

Side note: Your personal site isn’t showing. Maybe when you get time you can fix that too?

I will do that with the csv, thank you!
And yes, my site is on pause for now as I can’t take on any more clients. Will put it back up when I slow down lol