Streaming live at 10am (PST)

404 Page for all items in news cms collection

Hi all,
I have tried to find a solution to my problem, but no luck so far.

I have created a second cms collection. However, whatever I do, all pages in it lead to “404 Page not found” once publsihed. Works as usual for the other CMS collection.

I was wandering if someone could be so nice and have a look at it?

This is the site: berni.blog

Thank you so much for any tips and help,

Berni

MOD EDIT: Credentials removed.


Here is my public share link: LINK
(how to access public share link)

Please include your site’s Read-Only Share Link with your question.
A read-only link allows the community to view your project without making any edits to it and help diagnose your issue or provide feedback.

If your project has custom code or layout issues on the published site, please share that URL/URI as well.

Hi webdev,
thank you for your quick offer to help.

Sorry, I’m new here indeed.

Here is the share read-only link: Webflow - Berni

Thanks again,
Berni

@Berni - I believe the “wealth” posts produce a 404 because there is no template content, so no pages can get rendered. Try working on that CMS template and then publish and check again. See if that resolves your issue.

Hi Jeff,

thank you so much for your help. I’m not entirely sure what you mean by “no template content”?

Under “Wealth” so far I have to “example posts” that Webflow generates.

These are the template settings:

And this is how a template filled out looks like:

Do you see anything wrong with that? Or where could I work on the CMS templates?

Thank you again,

Berni

You’re only creating CMS items, but there is nothing in the CMS Collection template to display them. You need to design a page with fields that the CMS collection items can populate.