Streaming live at 10am (PST)

504 Gateway Timeout

Every other day I get the 504 Gateway Timeout screen where the page doesn’t load.

Is this something Webflow are aware of? Is there something I can do to fix it?

Hi jonnym, I am also getting 504 Gateway Timeout error pretty regularly. It started about 2 weeks ago and now I get this error message multiple times per day for my websites.

Something that worries me quite a bit. Will be happy to hear feedback from other users if this is happening to them as well.

Same, it’s a major concern for me. I’m building microsites within one Webflow hosted website and I’ve had clients stop working with me due to the error.

Is this related to the “Error: Publishing timed out” issues I’m having this morning? US East Coast, internet otherwise is working perfectly (i.e,. this forum).

At 11:58PM

Again now at 12:05PM

Hi TG2,

I do not know if these two issues are related, these might be.
Bug that I am getting occasionally is Error 504 when I browser my sites:

1 Like

I’m getting the same issue as @lukaso

Its been happening for weeks and I’ve noticed others commenting with the same problem - https://www.facebook.com/groups/webflowdesigners/permalink/904090883436919/

Got the same 504 bad getaway issue on my site today for about 1h. Everything back to normal now. It looks like Webflow is aware of the problem as they mention having 500 problems in their customer support chat welcome message.

1 Like

Oh, wow, @lukaso. The actual site goes down? That’s terrible!

The Designer publishing issue did receive its own status here; I believe this 504 bug may be referred as the “dynamic content” bit?

As of 18:22 UTC (2:22PM EST), it’s been seemingly fixed & their monitoring for further bugs.

Hope all is well at the Webflow HQ these days: network / server-side bugs have gotten far more common in the past three months.

@Geebo thanks for info!

@TG2 yea it is pretty unfortunate - also for the reason that you need to actually browser the site to discover the issue, otherwise you do not know. Thank you for posting the status page, I also hope that 504 bug may be referred as “dynamic content” bit!

I have to agree that things have gotten worse lately - from my experience it was bearable as these bugs were only happening in Editor making the work slower. But this is the first time with that 504 error that bug is actually affecting site visitors.

1 Like

small update: I got the message from Webflow support that issue has been resolved. However, it is still occurring on my end.

I’m still getting this error. Can someone in the Webflow team look into this please @PixelGeek ?

In the meantime does anyone know how to make a page refresh automatically on a 504 error as this typically fixes it?

I am also continuing getting this error. It is a really big deal.

Hi,

last days it got worse and I am continuing to see 504 on my website regularly.
I do not have any response from Support yet.

Is anyone else having the issues these days?

Hi!
I am having the same problem. It seems to occur when I switch between tabs in my browser… And only in Safari. Does anyone know why this happens?

@Josefin happens to me on Google Chrome and not noticed any correlation to tabs!

Exact same problem here… It started 2-3 weeks ago, the pages take time to load for whatever reason once in a while. It usually works well but sometimes it’s blocked and then users get this 504 message.

A 504 error will occur when one server did not get a response from another in a timely manner. For example, a DNS contacts the web hosting server…
dfet

504 Gateway Timeout : The server was acting as a gateway or proxy and did not receive a timely response from the upstream server.

why is there no response from the webflow staff so far? I get this 504 about every 20 page-loads. Even on webflow.io subdomains

Hi Jeff - I’m afraid this is a separate issue.

The 504 error occurs on live sites on both webflow.io and custom domains - preventing users from using your website.

Is this something the Webflow team is aware of?

I moved off the topic I was intending to paste it into and ended up here by mistake. Sorry.