Streaming live at 10am (PST)

Accordion items are snapping back open after closing for some reason

Hey all!

I am working on a site for a client right now, and for some reason my accordion interaction on the Home and Staff Member pages are now snapping back to an open position after the second click to close. They were working fine as of yesterday, but today they won’t work for some reason.

This is a kinda urgent help-needed kinda thing. So if someone wouldn’t mind taking a look, I would appreciate it! :slight_smile:


Here is my public share link: Webflow - Mountaineer Spina Bifida Camp
(how to access public share link)

Hey Tyler, this is a quick fix. In your ‘accordion close’ interaction, add a new action that will be first in the list (do not set it to be initial state). It should set the accordion heading size/height to auto.

That would be fine, but it adds a half-second delay to the IX that wasn’t there before. My confusion is to why this is happening all of a sudden, as it worked fine before today. It is also happening on three different IX… 1) Accordion Close, 2) Staff More Info Close, and 3) Hamburger Menu Close

You can just set the new action on the accordion heading to have no duration… I just didn’t mess with that before and it has a .5s duration by default.

This is how I usually set up interactions like this so I’m not sure why you weren’t experiencing issues until now. Maybe someone else could weigh in on that.

Carly,

Thank you so much! This worked almost perfect, however there is one flaw. Whenever it closes, the second it fully closes, it will pop open again for a split second, then just back closed again. Any idea of a fix for that?

Thank you so much for the help! :slight_smile:

Interesting. I’m not seeing that! Perhaps do a webflow browser refresh - sometimes interactions act up if working on them so granularly for a while (I do not know why).

Here is what is happening on my end. And it does the same thing on the live site for me.

You can only see it for a split second on the recording, but when I actually did it it was doing it every time for me… Ugh :frowning: