Streaming live at 10am (PST)

Adding style to the link icon


#1

Hi
I have adapted a template which has styling for link that I want to change.
When I highlight a section of text that I want to make into a link and click the link icon it adds the original templates styling to that link. So I created a new link style.
However when I try to make a link in text as above it still uses the templates style. How do I ensure that when I click the link icon it uses my style?
Thanks


Here is my public share link: LINK
(how to access public share link)


#2

Hi @gazooooo all you need to do is add an inline text link style to that element as shown in the screenshot below:

Set the Display setting to "Inline", and remove the padding from the link. Thereafter you can style the typography for the link as well in the typography panel.


#3

Hi Waldo
Thanks for your help. My problem is that even having created my own link style when I select text and click the icon it always uses the style I don't want as below:
....how do I add a screenshot here?


#4

@gazooooo when you create a text link, you will need to add a Class name to the link to style it as shown in this screen shot below.


#5

OK thanks Waldo. Sorry to appear a bit thick but how do I use my style as the default style when I click on the link icon? As you can see, at the moment, the default appears to be as in your last screenshot.
Is that possible or do I have to choose the style in the selector each time?
Thanks


#6

Hi @gazooooo you can instead style the Global Selector if you'd like (note this would affect any links on your site that are using the global selector style and not a specific class for the style):


#7

Aha, I see now. Thanks Waldo. Much appreciated.


#8

Sorry Waldo, one more question - obvious when I know how I'm sure .... having added a link if I change my mind how do I remove that link short of deleting the text?


#9

@gazooooo just highlight the text or click into the text link and then click on the link icon in the canvas link inline style settings menu as shown in the gif attached. :slight_smile:


#10

Great - good gif - got it!
Thanks again Waldo.
I'm learning!
:slight_smile:


#11

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.