Streaming live at 10am (PST)

Alignment Question


#1

Hi all,

I have a question... for some reason the alignment on my faq im building is having some issues...

if you see attached I have click trigger interactions on the whole FAQ section so on click it will show the txt below thats invisible... it all works except if you see the alignment on the first two faq questions is set right how I want it (as shown attached) and the ones below have bigger spaces between them...

But when you click on the faq questions with bigger spaces it auto adjusts to then sit perfectly but only once you click it... Any ideas whats happening?

Heres the read only link: https://preview.webflow.com/preview/the-quiet-room30021136?preview=6faff9e7c39a862f9a8976ecedfbf772

Thanks


#2

Hello @mattmcs!

You created as many interactions as you have list items (answers). But they are all the same. It cause mistake: you forgot, that in 1st interaction (initial hiding answers) you did height=0px, and in others you did not use that.


Then in open-answer interaction you are playing with height again.

So you have to fix your interactions


#3

But really you don't even need so many interactions and lists. It is how I would do that:

1) Create 1 list and 10 list-items in it

2) Inside every list item add link-block (for make cursor change on "hand-pointer")

3) Inside Link-block add 2 text-blocks with classes "question" and "answer"

4) Create 1 interaction "initial-hide-answer", apply it to EVERY answer


5) Create 1 interaction "open answer", apply it to EVERY question.


How to create a FAQ Page like this: https://www.snappr.co/faq
#4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.