Streaming live at 10am (PST)

All CMS items appear in page code


#1

Hi everyone,

I have an issue with CMS items in the page code. On my page (e.g. https://www.ajimba.com/de/placeholder-soon-to-come) I have the header image and the header text coming from the CMS. It works wonderfully, I always see the right picture and the right header.

My problem is, that in the background (page source) all other items of the CMS table are also shown, with condition ‘invisible’. But obviously it created 20 or so

tags and that distroys my SEO efforts.

Here is my public share link: [https://preview.webflow.com/preview/ajimba?preview=2366c98041242551c59737b86c76012d. You can find the example on page ‘placeholder-soon-to-come’

Does anyone have a idea, how I can prevent this from happening?

Thanks a lot, and greetings from Bremen,

Holger


#2

Have you had any update to this? I am realizing this myself in a similar way.
I’ve created a CMS called Services, and on each service template page I have a non-binding section that’s just for that one service. And so I filter it to only show on a specific service name.
I did this four time for each of the four services.
I went to the live page and noticed that the other three services “hidden” section is listed in the code of that page.

I started looking around Webflow as I’m curious how this affects SEO and Page Load.
Since, its’effectively loading more content that’s not visible and also content is then duplicated.

:confused:


#3

Good morning, no, unfortunately I did not get any response. I was only able to solve it by copying and altering another CMS section without this effect. I still have no clue where the error was. But at least it is working now. I guess, the influence for SEO is quite big, thus I wanted it solved.

Good luck! :four_leaf_clover: