Streaming live at 10am (PST)

Anchor links in header menu don't work from other pages

Hi all,

I’m stuck trying to figure out anchor link behavior from one page to another:

From my home page, with the link being set to a section of the page, the nice animated scroll works like a champ. I only have 2 pages. From my blog page, the menu navigation doesn’t work at all. I suppose this makes sense - the sections being linked to don’t exist on that page. Ok.

Do I just have to duplicate my menu symbol and change the links there? If so, how? I’ve tried updating the link to be a specific URL instead of a section and setting it to /[page name]#[section name] but anchor links don’t seem to work at all from any page except the home page.

https://wishlist.webflow.com/ideas/WEBFLOW-I-181

This wishlist item makes it seem like it’s not possible at all?

How can someone on my blog page reach a particular section of my homepage from the navigation menu?

Thanks!


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi @davenovelli, maybe you should use https://yourdomain.com/#section_id ?

1 Like

Well I tried it as “/#section_id” but that breaks the link in the design view (links to “webflow.com/#section_id”.

And I read on a forum post I could use “/page_name#section_id” but that didn’t work either.

I want to keep the site at domain.webflow.io as a test site since I have features that definitely won’t work in the designer, but I also want the links to work both on that dev site, and on my custom domain.

I certainly may be missing something though!

Correct, but the published version will work fine. This is still the recommended action, unless you use absolute URLs to your primary domain.

1 Like

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.