Streaming live at 10am (PST)

Anchor links not quite working

Basically this post:

I’m having some issues with basic anchor links…
I’ve got a nav menu with nav links to 3 sections.
each section has an id, and the nav links are set to sections with the corresponding id

the anchor links don’t seem to work on the published working site, however, on the preview, they seem to be working??

I tried @Jeandcc fix that he put in this thread, but that also hasn’t worked yet.

any ideas?

thank you,

https://taylors-groovy-project-2cf291.webflow.io/

https://preview.webflow.com/preview/taylors-groovy-project-2cf291?utm_medium=preview_link&utm_source=designer&utm_content=taylors-groovy-project-2cf291&preview=5614ff10475fed6e13bc269cb91ff21a

Have you tried changing your navlink type to Section instead of External URL?

yeah, that is what i had originally.

after looking through solutions, @Jeandcc mentioned doing this in a video:

  • still not working for this situation unfortunately

Can we test something? Can you remove all the custom code you have for that page/website and let me know if it still fails to work properly?

Just removed all custom code from the page - and it still fails to load on publish

Are you sure? I’m still getting all those errors. Make sure to remove the ones in the project settings as well

gotcha, forgot to have a look at my project settings custom code - outside of the designer…

i guess it had something to do with the smooth scroll js??

thank you for your help!

Precisely. Take a loot at smoothscroll documentation so you can set it up properly on your website. It seems like you didn’t provide a valid container element to be scrollable

1 Like

I’m having this issue as well, no custom code either. My anchor links work correctly in the designer but when they’re published they break on all other pages except for the page that they are supposed to link to.

TLDR: Section anchor links don’t work from booking & bio pages > homepage after publish.

In designer:
Screen Shot 2020-05-21 at 4.18.30 PM

On published site:

You can see this behavior here:
studiotrusalon.com