Streaming live at 10am (PST)

Animated image over Navi

Hi everyone,

I wanted to give some interaction into images.
This is a tutorial I followed.
(https://university.webflow.com/lesson/reveal-elements-on-scroll-interactions)

But after I set the interaction, the images with interaction are displayed over the Navi.
If I remove interaction, it works fine again. I don’t know what’s wrong :frowning:
Please watch the video below.

This is read-only link of my project
(https://preview.webflow.com/preview/hyejins-beautiful-project?utm_medium=preview_link&utm_source=designer&utm_content=hyejins-beautiful-project&preview=b333b977a6eb665584e06ff2bc81aa3e&pageId=5e248730992bfac6312d6578&mode=preview)

Please let me know if you know how to fix this problem.

Hi @hyejin,

Welcome to the Webflow Community.
Plenty of willing helpers in the community, so you’ve come to the right place to get help when you need it.

An easy fix to get the desired result is to set a ‘z-index’ on the ‘Nav Detail’ element.
The ‘z-index’ is like ‘layering’ your elements on the page. The higher the number (z-index) the higher the layer it will sit on your page and everything else ‘sits’ below/under it.

See image for settings:

Hope that helps,
Keiran

1 Like

Hi Keiran,

Thank you so much!! I didn’t even know ‘z-index’ exists :joy:
It’s easily fixed by z-index.

Have a good day!

Best wishes,
Hyejin

1 Like

Glad that it was what you were after.

Please mark as solved in case someone else searches for the same issue, then they will know how to fix.

Cheers
Keiran

@knk

I checked your reply as a solution. Is this marking as solved?
or is there another button?

Best,
Hyejin

Hi Hyejin,

it looks like one of the community moderators had already marked it as solved.
No other button - All Good.
Keiran

Hi knk,

I see, thanks! :smiley:

1 Like