Streaming live at 10am (PST)

Any ideas why scroll to element isn't working?


#1

Any ideas why the scroll to element function isn't working? I believe I have everything setup correctly : In-page linking ID is set and the URL is changing so it's firing correctly but no scroll action...


Here is my public share link: Home Page


#2

Can you tell me which link isn't working? I only found links to other pages. Scroll to element only works on in page links.


#3

Hahaha that would help huh?
The down arrow on the home page...It should scroll to the main-content section


#4

I honestly have no idea. Seems like a bug. But I should mention, is there a reason why your hero is a symbol? Also, your second section is set to a main tag instead of a div tag. Not sure if that makes any difference but I've never seen that tag used before. @cyberdave @sabanna Can either of you chime in?


#5

@Marky_Coulstring

Had a look on your problem and the reason it doesn't scroll is because of your body class "overflow-hidden". You had set that to Auto and that somehow disables your scroll interaction. I deleted that.

I also set your main content section to the tag of "Section" (instead of Div) and renamed the ID to "main". Seems like single word ID's works best. I had this problem too in the past and since then I always go with single word ID's for my sections.

These changes made the scroll trigger on your down arrow to work.


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.