Streaming live at 10am (PST)

Anyone else facing serious lags with Webflow when publishing sites?

I’ve seen issues posted relating to Webflow being slow and laggy in general but is anyone facing issues with lag when publishing their website?

Here’s the general pattern I experience:

  • The first Publish of any session is almost always super quick; published within seconds…

  • Any following Publishes take almost 30 seconds and even when Publishing finishes, the “Close” button takes another few seconds to become active… and even then, cannot be pressed for another few seconds. So almost 45 seconds per Publish.

Because of this, testing incremental changes on different devices and breakpoints to optimise for responsiveness takes forever…

Anyone?

Hey there!

I don’t think I have seen any issues like this. Usually publishing takes about 10 seconds at most for me, and then is live on the site within a couple seconds.

How large are the sites that you are publishing? Most of the sites I have built thus far have been relatively small in comparison to others. It may just be taking Webflow longer to compile all the files, code, etc. and push it to the web.

1 Like

Thanks for the comment, Tyler.

Relatively speaking the site isn’t that large. 10 pages or so, with many of those mainly text (cookies policy etc.). I do have e-commerce functionality and a couple of CMS and product collections, with a number of interactions… But at the end of the day I’m assuming Webflow only publishes the changes that have been made and not the entire site every single time…? Here the changes are incremental when making adjustments to optimise for various breakpoints.

(After I posted the original post, I started getting pop-up messages in Chrome, asking if I wanted to kill the page or wait for a response; it was taking that long…)