Streaming live at 10am (PST)

Anyone getting a "SSL handshake failed" (525) error on their Webflow site?


#1

Our site https://www.gethapi.com.au is currently down due to an SSL issue.

Screenshot: http://b3.ms/j0oM8awL9xyL

We've not touched any DNS / SSL settings for months, and all of a sudden it's down... I wanted to see if anyone else using Webflow's SSL add-on is experiencing similar issues.

Thanks.


#2

Hi @johnnymitch I'm not experiencing any issues with my SSL enabled sites.


#3

You have to provide us your cloudflare settings as it is hidden from public view.


#4

Hmmmm quite odd! Thanks for replying.


#5

Here's a few screenshots:

  1. http://b3.ms/yYLn7d6yMGgZ
  2. http://b3.ms/W1EnJ0Wb9ZRX
  3. http://b3.ms/z2VnmlykAg3y

Note that from the Webflow screenshot, it has errors, but it has been that way for 2-3 months, because we use three domain extensions (.me, .com.au and .co.uk) with no default domain, for localisation purposes.


#6

I'm not seeing that but you're welcome to check my new company site, comprised of 6 different WF sites combined due to the page number limitation. The total website has a lot more pages than allowed on one WF site. If you find the issue you are speaking of, I would welcome the notification. Thanks.


#7

I've just switched my own site to Cloudflare and saw this issue. I think I've managed to fix it.
I have 2 domains, and want to use the root of one of these as the default. I.e. all traffic goes to here.

Firstly, the settings I'm using in Cloudflare are fairly simple:
1. DNS is 2 CNAMES, one (flattening) for the root, another for www. Both values are proxy-ssl.webflow.com.
2. Crypto SSL is Full (strict) - I didn't notice any differences between strict or not.
3. Auto rewrite HTTPS is on, again didn't impact results.

In Webflow, my site settings are, and these are pretty obvious:
SSL on, with both custom domains added, and the default being the root domain I want (make sure you publish after changing default).

So, to fix it, I simply turned the CNAMEs to DNS only in Cloudflare (the orange cloud). Up until this point, Webflow continuously reported the domains as unlinked in the hosting setup. As soon as I changed to DNS only, they were then linked and things worked. I could then set the default domain to my root and it all was fine.
Whats now strange, is that when I turned the DNS + Proxy back on in Cloudflare, the domains all seemed to continue working...but doing a refresh on the hosting page in Webflow, now shows all of the domains as unlinked...

It's been a few hours since I've resolved it now, so hopefully any delayed propagation has happened, and what I'm reporting is actually the truth.

Hope this helps in any way, good luck!


#8

@johnnymitch and @dylanj.nz yep, that's the correct solution.

Since we're providing you with the SSL Certificate from this end, you just need to use Cloudflare as your DNS provider or else you'll get that error after 60 days.

You do this by clicking on the Orange cloud icon next to your root domain CNAME and your subdomain CNAME records which are pointing to proxy-ssl.webflow.com and it should turn grey and change to "DNS Only" for the value if you hover over it.

So your DNS settings in cloudflare for your domain should look like this:

Be sure to change your TTL to 2 minutes so that you get the fastest DNS record update possible. Thereafter you can actually check your DNS records here publicly: https://www.whatsmydns.net

Thereafter you can publish your Webflow site to your custom domain again and so long as your DNS records are live, you should be all set to go and you should no longer encounter the SSL Handshake failed 525 error again.


#9

This topic was automatically closed after 60 days. New replies are no longer allowed.