Streaming live at 10am (PST)

Assets Images and Collection Grid Question


#1

Hi All,

I have two newbie image related questions.

  1. If you upload images directly into a rich text field, such as in a blog post, are those images also added to your Assets?

  2. Any ideas on why this grid display of images would skip two spots in the layout?

Thanks for any tips!


Here is my public share link: LINK
(how to access public share link)


#2

Hi @matt.bryant,

1 - I’m not 100% sure about the assets but my guess would be no it won’t. It could be quite cumbersome to have to deal with 200 images in your asset panel if your client/editor was posting new blog post every day.

2 - The gap is made because your images might not be the exact same exact aspect ratio and it will try to add the next item in the shortest column.

To test this, you can setup a fixed height on your Project Image and you will see the desired result. I covered a similar issue on another thread where I provide my preferred way of dealing with collection list grid using flexbox.

Here is the thread and you will hopefully find the answers you need.

But it will also work your way if you make sure all the images you import in the CMS are equals in height and width (or at least same aspect ratio)

Side note : CSS grid is coming to Webflow soon (it’s never soon enough :slight_smile: ) and it will offer a whole new world of layout possibilities. Combined with flexbox sky is the limit.

I hope it can help you.

Max


#3

Hi @Maximosaurus - your suggestion for the layout grid worked perfectly, thank you!!

As for the assets, in reviewing the Assets feature in Webflow University, it seems to me that anything that is uploaded or added to the project is added into the Assets. Which is strange in my case for the project linked above, as none of those images/collection you see on the canvass show up in my Assets. It would make sense for images to be stored separately from the point of view that each image typically has multiple variants created for responsive loading. Hmm…now I’m worried that my images aren’t really loaded properly!