Streaming live at 10am (PST)

Audio Problem - Please help Urgent


#1

I have read the blogs about embedding an object that relates to an audio file, but how do I command it to play?

The idea is when it goes to a page it will start playing - how do I do this?

And can it be hidden?

I also read about putting something in the head portion of the code ?

Do I give a class to the embed audio?

Would appreciate your help! Really stuck and not sure what to do.

Thanks!!!


#2

Hi @ananya

This article might help you: http://www.w3schools.com/tags/att_audio_autoplay.asp


#3

Thanks for your reply @PixelGeek

Do I add this to my body in webflow:

<audio controls autoplay>
  <source src="horse.ogg" type="audio/ogg">
  <source src="horse.mp3" type="audio/mpeg">
  Your browser does not support the audio element.
</audio>

I have a .wav file - how do I upload it to webflow? or I have embed code from the website?

Also, how does it link to the page I want ?

Sorry about the questions - I am not sure how to go about this.


#4

Hi @ananya, thanks for your followup. That is the correct code. You will want to put that code into an embed widget, where you want the audio player to appear.

See this article on the embed widget: http://help.webflow.com/site-settings/custom-code#adding-embed-code

Make sure to replace the path to the audio file in the lines:

<source src="horse.ogg" type="audio/ogg">
 <source src="horse.mp3" type="audio/mpeg">
<source src="horse.wav" type="audio/wav">

If you only have a wav file, then use that. The other file formats are for browser compatibility.

Webflow does not yet have file uploads other than images, however you can upload your audio file to dropbox, then get a share link to that and use that in the source path to the audio file.

I hope this helps ! I would add that to a site, then post back here on this post your result !


#5

Thanks @cyberdave. i did put it but it is not playing it for some reason - A mess up on my part.

Here is the link to my file - it is on the slider page 2.

https://preview.webflow.com/preview/testmemories24042744?preview=ebfe26e592e210fb495ba577c255486a


#6

in your embed code, find "dl=0" and change it to "dl=1"

​Try these steps and let me know if you're successful.


#7

Changed it - but did not work frowning


#8

darn frowning

ok. How about uploading that file to soundcloud?

Here is an example:
http://audio-demo.webflow.io/

Here is an article on how to set an autoplay to the embed widget:
http://help.soundcloud.com/customer/portal/articles/567116-how-do-you-make-an-embedded-player-autoplay-

hope this helps smiley


#9

Thanks! Uploading to sound cloud and will give that a try also.

In terms of the location where it is placed - wont matter. like in the body or in a section ?


#10

place it wherever fits best in your design smiley


#11

YAYAY - IT WORKED !!!!!

Thank you so much @pixelgeek


#12

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.