Streaming live at 10am (PST)

Auto Generated Columns in CSS Grid

Hey,

I have setup a simple grid with 4 Columns and 4 Rows but Webflow keeps auto generating two more columns. How do I get rid of them?

Screenshot of Grid Settings

Every Grid Child is positioned manually with Column Start 2 / Column End 3 and aligned Auto. I found another thread here in the forum where it said every child should be placed Auto. I did that.

Screenshot of Grid Child

Any Ideas what I’ve messed up here?

And sorry, I cant share the site at the moment because it’s under progress and underlies multiple nda’s.
I hope you can understand that :confused:

Thanks in Advance.

Edit 1) I just inspected the site in the Browser and found out If disable grid-template-areas in the developer Tools it seems to work. There are now only the four columns I want. Seems like there is a fith and sixth column If grid-template-areas is enabled though.

You, my friend, are a lifesaver. Your solution was dead on! At some point, I enabled areas and even though I never use them, it was creating the exact issue you described. Thank you!