Streaming live at 10am (PST)

Autoplay on slider after webflow code has been exported


#1

Hello

Title pretty much says it all. I am looking for a way to get the slider to autoplay after its been exported from webflow.
I'm currently looking through the javascript files but I haven't found anything yet.

If I find out the answer I will be sure to update here. I searched for answer but was surprised to see no one had asked this.


Here is my public share link: LINK
(how to access public share link)


#2

Hey @steelesong i'll have a quick look into this for you :). But first your public share link is blank, please update it for me so i can take a look at your project.


#3

No problem. I updated post.

Not sure that it matters but on my site I have taken out the 'filler' content you see in the webflow editor.

I have not touched any javascript files or changed any kind of class related to the slider. I just put different text in.


#4

Hey @steelesong I just took a peek and it looks like you didn't have the Auto-Play slides check box checked in the slider settings. Let me know if that does the trick or if you're still having an issue.


#5

Yeah I get that. The problem is that I've exported this code long ago and have been editing it manually. I'm asking if there is an easy way to turn autoplay on AFTER exporting it from the webflow app. Like perhaps a variable in webflow.js that I could change.


#6

Hey @steelesong in the HTML you'll notice your slider div has some custom data attributes. Look for data-animation="slide" and paste next to it data-autoplay="1"

Hope that helps!


#7

BAM. YOU ROCK!

The reason I love webflow so much is because of its easy to read code that it exports.

Any chance you could point me in the right direction for how long the slides pause before sliding to next one?


#8

No problem! I believe you need to add data-delay="4000" and change 4000 to something you want (in mili seconds)


#9

That was it. thank you so much. Do I have to close this post?


#10

:smiley: someone else may benefit from the info on here best to leave it open


#11

@steelesong what you also could have done is to make changes in the Webflow designer to the slider with the desired settings; then re-export your website, open its html with a text editor, copy the slider part out of this new html and paste it into your 'old' html.


#12

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.