Streaming live at 10am (PST)

Autoplay Video in LightBox not working in Chrome


#1

Hey guys,
I have a Lightbox with a Youtube video in it. Autoplay works in Safari and Firefox but not in Chrome. Why is it happening? Any workaround?

-Amit

Here is my site Read-Only: https://preview.webflow.com/preview/nurtch-executablenotebooks?preview=dc9047e10a279a73a313cabdd21bd0c7


#3

@Amit_Rathi

Thank you for bringing this to our attention!

Our team is aware of this issue and we are currently working on a fix. For the moment, as a workaround, you can create a custom Lightbox with Interactions.

I’ll keep you informed, as soon as we have an update on this issue - Thanks in advance for your patience!


#4

Hi, read about a new policy on Chrome:


#5

I read the new Chrome policy. It makes sense to block autoplay when you first land on a website. But clicking on LightBox image is an explicit action by user to play the content. It shouldn’t require an additional click after that.

Is there something wrong with LightBox implementation in Webflow which makes Chrome thinks that user has just landed on the site?


#6

Also, muted videos are allowed to autoplay. How do I get that working? My video has no sound anyway.

Muting is turning out hard because there is no parameter argument to youtube url to mute the video (mute=1 doesn’t work). Other options seem to need me to access HTML of iFrame which is not permitted because of cross origin.

Any ideas on how to get video to autoplay in muted mode?


#7

Hi @Amit_Rathi

Thanks for your patience and understanding with this autoplay issue.

Our team is working on a way to counteract this Chrome update, as clicking on a lightbox should be enough user interaction to play the video. I don’t have a time frame as to when this will be resolved, but we are working towards a solution.

For now, you can workaround this by changing your default settings by visiting this page in Chrome settings: chrome://flags/#autoplay-policy

Then switching your browser autoplay settings from “default” to “no user gesture is required.”

I’ll update this post as soon as I have more information or when the team has a solution.


#8

@Brando Thanks.

While your team resolves the issue, it would be great to get muted video to autoplay. The policy clearly allows it: https://developers.google.com/web/updates/2017/09/autoplay-policy-changes


#9

Great point @Amit_Rathi – thanks for the suggestion. This is something we are also looking into as a solution and I’ll definitely keep you updated when we’ve flushed it out a bit more.