Streaming live at 10am (PST)

Avoid http:// when hyperlinking a button with image


#1

I searched the forum but could not really find an usable answer.
So I hope someone here can help me.

I have a Link Block with an Image in it.
When the user clicks on this image, it triggers a link/action:?action=stop

But there is no option to avoid webflow putting http:// in front of it, so the produced code looks instead of: href="?action=stop" like this: "http://href="?action=stop"

I read on the forum that I can fix this with an Embed component, which I tried, but then I was not able to put my image inside.

Of course I could change the code after exporting by hand, but the thing is that there are a lot of those buttons and I'd love to see another box in the Link Settings which is called something like Empty

How can I achieve an image with a hyperlink without http:// in front?

Here the link to the site:
https://preview.webflow.com/preview/pocketvj-cp?preview=b5449f4224d9eb59e480e318ff6cf24c
(the stop button)


#2

Hey @Pocketvj did you try pasting the ?action=stop like this `?action=stop ?

The ` before stops the automatic http:// prefixing in the dashboard. Let me know if it works.


#3

@Alex:
Thanks for your help!

The ` sign in front of my link helps to avoid that Webflow automatically generates http://

Edit:
If you try to solve the same issue, but it kinda does not work, make sure its a ` sign and not ' sign.
They look pretty similar and I could not find out how to type the correct one, so I use copy and paste from this page...


#4

Help!

The same workaround does not work on buttons!

Is there another technique or is this a bug ?

Edit:
Its a bug, the workaround is as following:
Type in the link with the special sign, for example: `?action=stop
But Do Not hit enter or anything else in the link settings tab!!
Just click somewhere on your page, then it works....


#5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.