Streaming live at 10am (PST)

AWS Route53 - "This site can’t provide a secure connection"


#1

I’m unable to get my site working with SSL, but it works without it. I’ve followed the documentation, but there is no specific guide for how to set it up on Amazon Route53. I’ve done my best to approximate it, but no luck.

I found this forum post showing the same issue, but the resolution doesn’t seem to apply to Route53 (or maybe it does, I’m not a whiz with DNS records.

Here’s screenshots of the entries I’ve added:

A few key differences I’ve found in Route53 - can’t use “@” and can’t have multiple A records for the same record name (I just put the two different IPs for the root in the same record.

Here’s the settings for SSL (I’m switching back so my site isn’t broken while waiting for suggestions, but here’s what it looked like when it was broken)

Any ideas?

Thanks!
Dave


Can I hire someone to help with SSL configuration?
#2

I would definitely get AWS on the phone with - Server Support. And have them walk you through the setup while you’re in the Project Settings. This for sure is their responsibility. That’s what you’re paying for. :grin: Call them directly.


#3

Hmm I’m not so sure going straight to AWS is the play here. If they ask me any questions about how the certificate is configured I’ll have 0 answers. I feel like Webflow should know enough about their own SSL configuration to be able to provide some feedback on DNS settings for a major provider like Amazon.


#4

No because DNS is managed by the Registrar not an online application. Trust me, I’ve dealt with this a number of times. Webflow only gives you their cname, etc. But it’s actually located on the domain registrar and that’s where is ported from. Webflow is referencing from AWS. Just make sure the settings on AWS is absolutely correct first.


#5

What? Yes, I agree that DNS is managed by Route53 and not webflow - that’s very clear.

The rest of your explanation is not clear.

“Webflow only gives you their cname” - yes, Webflow tells me to use “proxy-ssl.webflow.com” for any traffic that is going to www.domain.com, and I set up the CNAME record for that. Meaning, if I visit “https://www.domain.com” that request will get routed by Route53 to a webflow proxy server, which handles that traffic with SSL.

Alternately, if I visit “https://domain.com” (without the www), that request will get routed by the A record in Route53 to one of two specific webflow servers, which are setup with SSL.

In either case, the traffic is being routed to webflow, where the SSL configuration lives. This error is not being generated by Route53, it’s being generated by a webflow server somewhere. Also, it’s the exact same error whether or not I use ‘www’ (the CNAME or the A record). So, again, traffic is being routed to webflow and they’re crashing.

I’m not suggesting that there isn’t a setting or something I need to change in AWS. (In fact, that’s exactly what I’m asking - what do I need to change). What I’m saying is that I followed the directions as best I could, but someone from Webflow should know what needs to change to get their servers to correctly accept the request from Route53.

AWS only knows that it’s successfully routing according to my settings - how could they possibly know what settings I need to change to get webflow’s servers to not throw an error?


#6

I’m also having this problem on Route 53.
However, I’m only having problem with the APEX record.

the www CNAME record works fine.


#7

This topic was automatically closed after 60 days. New replies are no longer allowed.