Streaming live at 10am (PST)

Background video isn't working on published site due to Chrome 66 update


#12

No problem glad to hear it! I try to help as much as I can on these forums and it’s refreshing to know that if I have a problem of my own there are so many people willing to help me!


#13

I have this issue on a site too. These autoplay video headers are grief.


#14

Hi @HammerOz, @PHRyan, we are taking a look these reports of bg videos not working and helping to get this resolved. An update will be shared as soon as there is some new info to report.

I know it can be frustrating when things do not work as expected, further info to come on this.


#15

Thanks @cyberdave. I am not blaming you guys. I was taking a look at this. I am not sure I see a fix at my end as my vid has no sound https://developers.google.com/web/updates/2017/09/autoplay-policy-changes. thanks


Background Video and Overlays
#16

Did you guys get this fixed? Just saw my background video in all its glory on my published site in Chrome 66.0.3359.139.


#17

Thanks guys for working your magic. It’s working for me now too.


#18

Hi there,

I have just replaced the background video on my website. The new video plays fine in preview
but when published it just shows the first frame.

Note: The video plays if I click on the home page logo link on site but not if typing in the URL directly to browser.

Any help would be much appreciated. The previous video I had worked with no problems and was trans-coded in the same way using Handbrake. Video is under 5mb

Thanks,

Niall


https://preview.webflow.com/preview/webcraft2018-2?preview=88a819c72917d317c766b3b3a4e2078f


#19

I have exactly the same issue including the video only playing on clicking the logo nav link.


Odd behavior in Mobile - Landscape view only
#20

I used you readonly link and it plays fine bud. Maybe its your internet speed?


#21

Here it is showing that it works


#22

Thank’s for the replies:

It works in preview mode ( Like the video posted ) when you click the eye icon. It does not work on the published site.

Further to making my post, I have found that it plays in IE and Firefox but not Chrome, I have tried many things but nothing seems to work.

Thanks,

Niall


#23

Idk I am not able to look at the published site, but if it makes any difference I did do preview mode on Chrome.


#24

Webflow are looking at it Background video isn't working on published site due to Chrome 66 update


#25

Ok - this is very strange but after HammerOz told me it was due to the Chrome update, I did turn off the Autoplay on the background video and then turned it back on again. Somehow it fixed this issue. So weird…


#26

Thanks for all the replies. It’s working now. Webflow have fixed it.


#27

One more example: https://www.atarilife.com/
The background video doesn’t work in 66… version of Chrome both on Windows and on Mac.

I have websites where there’s a background Youtube video that do work in this new Chrome.
Follow the tutorial attached.

But still I wait for Webflow’s resolution on this, because Youtube is blocked in China and we can’t use this Youtube solution for some websites.


#28

@cyberdave you guys fix this? My bg vid is working on chrome again


#29

Hi @HammerOz, thanks, yes, the awesome Webflow dev team has pushed out an update to add a muted tag to the background videos automatically. Let me know if there is any new behavior with that which is unexpected.

As a side note, I would recommend to republish the site project if the bg video does not autoplay right away.


#30

Nice one. Thanks to the team for sorting it


closed #31

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.