Streaming live at 10am (PST)

Background Video Removal No Load

Hello everyone,
So I’ve been working on getting a background video to play on my homepage behind text. It’s currently working as a section with a header and a button inside of it (on top). I figured out that when your iPhone is on low power mode, it doesn’t play the background video, but when you turn it off it works great! So my actually question is, Is there a custom code or option I can use to replace the frozen background video with a regular background image if the video is not playing? (As if a site visitor has low power mode enabled?). And when the video loads or starts playing, it makes the video appear.

Thanks!


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Not sure if I’m allowed to but… Bump

I’m not sure if this is a custom code issue or even possible in webflow. Any Ideas?

Hey there @ryanhelferich!

Feel free to check out this helpful thread when it comes to adding some custom code to allow background videos to play on mobile devices.

This might not work though depending on the device settings, as you’ve noticed when power-saving mode is on the video doesn’t play. There isn’t a way to try and override those settings with any kind of custom code.

Another route to experiment with is uploading a heavily compressed video to where the size is smaller than what is currently uploaded, that might help but it isn’t guaranteed based off of how the phone might read it as a too heavy of a resource to load/play.

​Hopefully this helps, and please feel free to reach back out if you have any more questions; I’d be more than happy to continue assisting.

My best,
Riley

You’re right and yes I’ve already come across that solution and idea. I’m trying to figure out if there is a way that I can detect whether the background video is playing or not, So if it isn’t playing then I can put a picture over the video to hide it. And then remove the picture if the video begins playing.

Still trying to figure out if this is possible, Bump

1 Like

same here, does anyone can help?