Streaming live at 10am (PST)

Basic page with div, background won't show?


#1

Ok, I must be missing something reeeeealy simple here. I have a page, and on that page is a DIV. I set a background image to that DIV and it doesn't show. I have literally done nothing else to my home page and I can't see the background.

Setup:

Body
- DIV

I have another page that does work but it is setup with a section and it works

Body
- Section (background set here)
-- Container
--- DIV


(Note the white space to the left)

So I thought...."Can I only add background images to 'sections?'. I then proceeded to add a section to the page and was going to put the DIV with in the Section but as soon as the Section was added(to the bottom of the element list mind you!), the DIV background showed!!


(note the image background colour to the left)

It seems that WebFlow is enforcing the use of containers, despite a basic body/div being perfectly valid html use.


#2

Seems to be working for me fine is it possible for a read-only link?


#3

This was more of a comment than a real problem. It was repeatable on my site.

You can take a look at the TEST page if you like, to see it in action. Once you see the blank page, just add a 'section' AFTER the DIV, then you see it suddenly go 'oh, I'll display that DIV background for you now'.

https://preview.webflow.com/preview/bjt-daily-ui?preview=629a035a0be5307ac17ef7c518b5a8a5


#4

I followed your instructions i placed a section after the div this is what happend: http://nimb.ws/snpjx1. :smile:


#5

@DragonDon

As you can see in the picture below i have not placed any section on the page yet the div still has a background image all i did is give the div 100vh :smile:

Best
Ahmad


#6

The video only shows you adding a section to a blank page.


#7

Actually, what was missing was 100% height on the body.

Man....you would think that if you gave 100% height to a DIV, and then put a picture inside of it, it would take up the full height of the picture.....ah well.

Also, VH is only partially supported. When I learned of it, started using it but it also gave me some trouble. So it's purely a chance that it works right for your site or not it seems.


#8

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.