Streaming live at 10am (PST)

Buggy/Jittery/Glitchy behaviour in Safari using default section scroll

Hi everyone,

Having issues with glitchy behaviour in Safari using default section scroll. (In chrome everything works as it should) The sites scroll-transitions work fine when i scroll through the page, but when the sections are clicked it goes crazy. It makes the site completely unusable in safari and will be forced to turn off the default scroll transition using data-scroll-time, which i would like to avoid.

Attached a video of the glitchy behaviour here:

I suspected that the glitchy behaviour had something to do with my sections layered on top of each-other however, i’ve seen others post about same problems who’s sites are not layered so assume it cant be that? Safari Bug - Section Link Scroll Animation

Any ideas anyone? Stressing out here :confused: :see_no_evil:

Here is my site Read-Only:

https://preview.webflow.com/preview/postlerfergusonsketch-7ea-9bd40f060c851?utm_medium=preview_link&utm_source=dashboard&utm_content=postlerfergusonsketch-7ea-9bd40f060c851&preview=a3f2d2cd07ce1afc22fabe3f0f3b0ea2&mode=preview

Published site:
https://postlerfergusonsketch-7ea-9bd40f060c851.webflow.io/

@vincent i know you have looked at a similar issue before on the project linked above, any ideas?
T

Many thanks!

Another note: It does not glitch in all safari browsers. In those that do lag I’ve also tried opening the site in private mode to make sure that no plug-ins interfere with it, but still no luck.