Streaming live at 10am (PST)

Button Formatting gone Wonky


#1

I promise I'm leaving home for a while so you won't hear from me for a few hours :-/

I still am working on this show/hide text thing, but now, I want to show/hide a different area of text with a second button, so I had to give a new class to the first button that I created so that the section shown/hidden/ is different for the new button. Hope that makes sense.

Anyway, if I get rid of the "button" class and assign it a new class (which seems to be the only way to fix the problem), all formatting goes away, which is fine. I begin reformatting the button, but when I put in a background color, it is only going behind the text, not filling the entire button "rectangle" that I envision in my head.

I had this problem with the first button, and I clicked something and it went away, however, if I try to apply a shadow to the entire button, it only shadows the area behind the text, not the entire rectangle. I added a color change on hover, and for a spit second, you can see that the color behind the text doesn't change as quickly - even in the browser.

I am now trying to create the second button and no matter what I do, I am having this formatting issue - everything applies only to the space behind the text. This time, my clicking is to no avail. All settings for both buttons appear to be the same, and I don't understand why the editor isn't treating the whole area background.

https://preview.webflow.com/preview/jump-fish?preview=880f58bcaa1475bd480c481181abc642

sigh you guys will be happy when I'm done with this site!
Thanks in advance.
K


#2

why not try and use the TABS WIDGET. You can style the TABS ROW to float left as well as the TABS within it. Then float right the TAB CONTENT.


#3

Change your display setting on the button from "INLINE" to "BLOCK":


#4

Thank you for the suggestion. I want the buttons to be vertically aligned, not horizontally.


#5

Much appreciated vlogic! I knew it was something simple. Thank you so much!


#6