Streaming live at 10am (PST)

Button top mystic


#1

Hi,

view minutes ago we published our new site. we tested it lot of times and now i have one little mystic thing. If you scroll down to the bottom of the page you’ll see a litte round button with an arrow to top. If you click this button you should jump to the top of the page.

the mystic thing is, that this button don’t work only at the homesite. all other sites are fine. i think it depends on that we have no slug for our homesite. And another mystic thing is, it works at the webflow site / server, but not with our domain.

Our live site / own domain:

The webflow test-site with same data:

Here is a preview link. Can anyone help me?

https://preview.webflow.com/preview/marke-mensch-natur1410501-d7c8bffc6fa8b?preview=bd776bc11f5829fb201c26d1035f8bc4

Thanks
Toby


#2

@Toby

Looks like you have a hard-coded URL in the button link: https://screencast.com/t/EhnwOYvkb

What you should do, is give your top content wrapper an ID (such as Top-Header) like here: https://screencast.com/t/VUkiEUyND9t5

Then, you can make the button link to that part of the page, like here: https://screencast.com/t/dEXGz50y80

Now, that should work on all the sites like here: https://screencast.com/t/CrgFhaAE

Let me know if this helps


#3

Hi Justin,

thanks for your support. I’ve tried your suggestion many times and wondered that it doesn’t work.
Than i have read a post from vlad. But it seems the webflow team is actually too busy.

Please have a look. I’ have given the my wrapper an ID “top_header” now and linked the button at bottom to this section. but look self what happens. A bit and nothing. Magic. :slight_smile:

I have set this only at the homesite.

https://preview.webflow.com/preview/marke-mensch-natur1410501-d7c8bffc6fa8b?preview=bd776bc11f5829fb201c26d1035f8bc4

For me it seems that a domain problem. i don’t no.

Thanks
Toby


#4

Hi @Toby

I see that you’ve manually created anchor links on each page. What you can do is use the “Link to a Section” setting which will allow your button to scroll to the top of each page.

Follow this animation to change the button link on all your pages:

CloudApp

As for the home page, you’ve added the ID on the fixed header. You need to add it to the content wrapper. Then, follow the same steps that you did for the other pages.

Please, let me know if this is helpful or if you have any additional questions, I’m happy to help further.


#5

:slight_smile: Hey…

thanks Anna for this easy hint. :slight_smile: Shit, i didn’t have this idea to add the id at my content wrapper. wink:

I have it integrated and it works fine.

Thanks and sunny sunday

Toby


#6

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.