Streaming live at 10am (PST)

Buttons from previous designer not laying out correctly


#1

Hello!

There is a page on this site (see share link) that has 3 picture links to three pages
that page is called “Enter a Boat” and is in the menu bar
when you go to that page, you’ll see three pictures that lead to 3 other pages.

The issue is on each of those pages’ phone views, there is a button on each page that says “enter a boat” and it looks fine on desktop view, but when you click on phone view, the button stretches all the way up through the section above it.

I tried to rectify this by just adding another section just for the button, I did that on the Rules and Procedures page, but it didn’t change how the button looks in the two phone views. I’m sure there might be some other issue with the section above it that could be the cause, but I’ve tried adjusting everything, and only by making huge adjustment to the top margin of the button can i get the button down to normal button size, 1000+ in horizontal phone view, and 2000 plus in portrait phone view, it seems like somethings not set up right. If you go to the other two pages (on the enter a boat page) you’ll see them in their state before hand.

Also the “intro” paragraph rises up the page before the section the paragraph is in does, I’m sure it’s a related issue but I don’t where the main error is that’s causing these issues.

thanks!


Here is my site Read-Only: https://preview.webflow.com/preview/holidayflotilla?utm_source=holidayflotilla&preview=42ef8dfc206da4ee5c7b3af5e9959085


#2

@SomeHack

I moved the button out of the section and see your issue. On the paragraph above it you have it set to float: left. If you change this to float: none it will fix your button issue.

See if that also fixes your other issue and let me know :slight_smile:


#3

Thank you so much, I have to fire off some emergency emails but I’ll check this out afterwards and let you know!!
Again REALLY REALLY APPRECIATED!!! ty!!


#4

Anytime!! Let me know if that works :slight_smile:


#5

And yes it looks like that fix you mention is working (can’t believe i missed that!) so again, thank you! You made my Friday end on a much better note, have a great weekend!!


#6

@SomeHack Thanks so much and glad I could help! Hope you had a great weekend!