Streaming live at 10am (PST)

Cannot embed SproutVideo in video element

#1

I cannot embed a SproutVideo in a simple video element. I am getting the following error: “Invalid Embed Type: Link”

Link to video: https://videos.sproutvideo.com/embed/a49dddb71817ecc52c/f76d95cfba59e747

I tried from a different account as well and getting the same error. SproutVideo is supported according to the documentation.

#2

Hi, @jmkriz!!

Thanks so much for reaching out about your video! I think the issue here is that you’re using the embed link for your video. Just like YouTube or Vimeo, we should just need the link to the video and not the embed code to get this to work.

Can you try just pasting the video link itself in and see if that works? :smiley:

I’ll be standing by to hear if that worked or not!

#3

OK, I got it to work with this:

This is the link to the video: https://rblt.vids.io/videos/a49dddb71817ecc52c/keynote-address-fintech-transforming-the-business-of-finance-and-insurance-mp4

1 Like
#4

Yes, I was just making you a video to show you where to grab that link:

CloudApp

So glad to hear you got it figured out! Let us know if you need anything else! :smiley:

#5

So FWIW, I figured out why I was having issues in the first place. I was using the correct link originally (the one I posted in my 3rd post there) but the problem was I was getting an invalid link error because the filename of the actual video I uploaded has parenthesis in it [e.g., video-3420-1 (1).mp4]. Once I removed the parenthesis from the filename of the video that I uploaded it worked fine. This is obviously a small use case, but in case anyone else runs into that issue… there you go.

2 Likes