Streaming live at 10am (PST)

Cannot Log Into Editor as Admin With Safari

#1

Hello,

I am able to log into the editor from the project context menu in the dashboard using Chrome and a Safari incognito window. However, the login prompt appears when I try to do the same from a regular Safari window. Is there something I can do to remedy this?

Thank you,
Scott

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

#2

I’m also having an issue with the editor right now.

I’ve tried accessing it through the dashboard and designer, it loads the correct URL but doesn’t have the bottom editor bar or button to open it up. Just a normal homepage being shown.

Browser: Chrome
Operating system: Windows 10

#3

Looks like there has been a recent change. I tested on safari (not logged in) and /?edit triggers the bottom authentication overlay. When authenticating as the account admin, I get a warning message stating “To access the Editor as an admin user, please use the Editor link in the Webflow dashboard”

I had no issues using that method.

#4

@webdev @skellogg

Thanks for posting here.

@skellogg — It’s expected behavior for Webflow account credentials to not work when trying to login to the Editor using /?edit. That method is only used for Collaborators who don’t have access to the Designer & Dashboard. To access the Editor as the site owner, you’ll need to use the Editor buttons located in the Designer or in the Dashboard. If you want to access the Editor in Safari then, you’ll need to first log into your Webflow account within Safari, then press the Editor button.

@itsaaronward regarding your issue:

I’ve tried accessing it through the dashboard and designer, it loads the correct URL but doesn’t have the bottom editor bar or button to open it up. Just a normal homepage being shown

This is typically caused by one of two things:

  1. Custom code that’s interfering with the Editor interface — to test for this you can delete any custom code that’s site-wide or on the home page
  2. Styles applied to the Body element. If you have, for example, a child perspective set on the Body, this can mess with the Editor interface as well

I hope this helps, and let me know if you are still having trouble loading the Editor, @itsaaronward.

1 Like
#5

Hey Brando!

Thanks for the response, I honestly tried nothing as I had to head out yesterday.

However, I did just open up the site and it seems to be working without any troubleshooting :eyes: — so I’m not sure why it was being a pain yesterday.

1 Like
#6

Definitely weird! Happy to hear it’s all good now though. Let us know if you encounter that trouble again :bowing_man:

#7

@Brando

The process you describe is the expected behavior, but I am still prompted by the login at the bottom of the screen after following the steps.

Thank you,
Scott

1 Like
#8

Are there extensions in Safari that are enabled? If so, try disabling them to see if the issue persists. You may need to delete site cookies if not.

Plug-ins that support Private Browsing stop storing cookies and other tracking information.

Let us know after you checked.

1 Like
#9

@webdev Deleting site cookies took care of the issue. Thank you!

closed #10

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.