Streaming live at 10am (PST)

Can't connect CMS page to a link block

Hi, I am a beginner to Webflow and bit stuck.
I have created the CMS collection. Created the page to display that collection. However, I can’t get the (Get URL from collection page) Almost every tutorial I saw has that “Get URL from”.
As you can see in my screenshot, I can’t get the URL from any CMS pages and hence, I am not able to connect any CMS page to a link block on my homepage.

Live link https://preview.webflow.com/preview/test-13d171?utm_medium=preview_link&utm_source=designer&utm_content=test-13d171&preview=129e2f063755a84dcf64605bfa1d520f&mode=preview

[2]: https://university.webflow.com/article/sharing-your-sites-read-only-link

Hi @nitish_vashistha,

This is because you do not have the “Collection List” anywhere on your page.

Step 1
Insert the Collection List element. Flex it horizontally.
2019-10-26_10h30_04
I inserted it directly into Section 2 for the purposes of this guide (I didn’t use Columns).
2019-10-26_10h30_24

Step 2
Open the Collection List settings and connect it to the CMS collection “Blog Posts”.
2019-10-26_10h34_03

Step 3
Do the same as Step 2 for the Collection Item.

It should now look like this:

Step 4
Go into the Settings for the Link, Picture and Text elements within the CMS Item, and connect them to the CMS collection. It will now look like this:

The reason that the images and link titles don’t look the same as in the preview that you posted, is because you need to change these from within the CMS Blog Post itself. These five were automatically generated by Webflow for you. You can access them here… try changing text, images etc and see how it changes dynamically on your page:

I strongly advise you to go through all the tutorials available in Webflow University - This is how I learnt to use Webflow CMS! https://university.webflow.com/category/cms

Good luck, let me know how you get on.

(If things like text etc look slightly different to the examples I put above, that’s my fault as I did it then went back to dissect it and take screenshots for you. The end result should be the same though)

@Andy_Vaughan Thanks a lot for the help.
So, here’s how I have structured site:

  1. I designed and created home. Put some elements.
  2. One of the div > I created into a link block (Now if a user clicks it, it should take them to my blog).

On the CMS side, I created a new collection > a page of it gets automatically created in the page section>I clicked on that page > created text box and bind collection elements/fields in it.

Now I am going to home, selecting a link block and trying to connect it to that (CMS collection page) Which is where I am not able to (Get URL from collection)

I can drag/drop CMS list on my home. But that’s not what I need.
I just need to connect one of my element to CMS collection page so when a user clicks on that element, they are taken to the new page(CMS collection page).

Maybe I am missing something very basic here. Let me know if I am able to explain my blocker.

Morning,

Yep so I’ve taken a look and seen that you’ve bound the CMS Page Template to the collection - all good.

So what you need to do now is follow the steps listed above. You can’t use an ordinary link block to dynamically connect to your CMS Collection, you need to use elements nested within a Collection List.

So at the moment, your div structure looks like this:
2019-10-27_12h58_14

Try getting it to look like this (by following the steps listed above):
2019-10-27_13h00_36

Ensure that Collection List, Collection Item, Link Block, cardimage and card gead are all connected to the CMS Collection from within each element’s settings.

The end result of following those steps, once each element within the Collection Item is properly linked, is this:

Clicking each link then takes me to the appropriate CMS Item page.