Streaming live at 10am (PST)

Can't delete elements


#1

Hi there

I can’t delete or reorganize any element.
Browser freeze (tested in Safari and Chrome)!

Only the W link in the left top corner works…


#2

I’ve noticed that it is only one element on thestart page.
all other elements are no problem.


#3

Hi @mark_artos

Can you share your read only link please and let me know which element it is that you cannot delete?


#4

Thanks for your replay. Now i deleted the parent element. That worked and i recreate the rest.
I had only a few elements in it and symbols so it was easy.


#5

Now i have the same problem with another element.
I can’t move it or delete it…

Have to reload the site to work again.

Here ist the site link.
https://preview.webflow.com/preview/appatrade?utm_source=appatrade&preview=0d1137f4c23bd269917c0e8345119394

The element is on the Sonderangebote site in the collection and has the class rabattpreis


#6

I am having a similar issue. Most of the elements on my pages seem to be working all right based on my quick click around, but when I go to the Service and Support page and attempt to edit “Text Block 18” in the dark gray box under Service & Calibration my entire Designer freezes. I am not even able to delete the element itself.

My read only link is: https://preview.webflow.com/preview/defelsko?utm_source=defelsko&preview=67a77cb9ca5c807501669fe7749659c0


#7

Yes its the same problem. I can move your element in the same column but move it to another column the designer freeze.

Very strange behavior.


#8

Confirmed. Nine gajillion error messages in the javascript console when I try to delete that specific element. I can alter or delete other things without issue.


#9

Yeah, once I touch that element the entire thing freezes and I need to close out the tab and go back into the Designer - only to have the same thing happen again.

Anyone have any idea what a possible fix might be? We launched a new backend site feature this weekend and I need to update these main pages accordingly ASAP.


#10

I figured out a workaround for you. It is far from ideal, but at least in this case it should get you back on the road.

Select the Text Block 18 element. Copy/paste it (I did it with cmd+c/v, but you can try right-clicking if you want).

Your layout will look broken now, but select the duplicated text block that is ontop of the yellow bar, and then in the styles panel on the selector, click on the class name and choose “Duplicate class”.

It will automatically name the element “Text Block 18 copy”. Just hit enter, then set that element that you just renamed to display: none. Edit: If you’re exporting this for further development, you may want to add the word “IGNORE” or “REMOVE” to the class name or something, so the developers understand what’s going on.

You should now be able to edit or delete the remaining Text Block 18.

Let me know if that works for you.

Note: If you try to delete the Text Block 18 copy, the remaining Text Block 18 will revert back to the bugged status.

Note Note: I don’t know if you’re having the same issue elsewhere on the site, but until this gets cleared up and/or checked out by an engineer, I’d try this method for any element that gives you the same problem.


#11

I was playing around with it some more, and I realized that if you just add a combo class to that Text Block 18 element, you’ll be able to edit or delete it with no errors. That’s a way more convenient fix.

Edit: Scratch that. I just reloaded it and realized that I can delete the element without making any changes at all. So the issue may actually have just gotten fixed.


#12

Yours appears to be fixed as well.


#13

Yes, I went on lunch and came back and now mine is fixed as well. Thank you for your detailed help @cricitem! If I do find any similar issues I’ll follow the steps you outlined.