Streaming live at 10am (PST)

Can't delete unused styles

I started designing the homepage of a new site but at a certain point of complexity was experiencing behavior that I did not understand and couldn’t correct, so I duplicated the site, deleted everything in the Navigator (except for the Body, of course) and chose “Clean Up” in the Style Manager in order to delete all of the existing styles so that I could start over.

05%20PM

However, despite the fact that none of the styles in the Style Manager are being used anymore, it won’t delete them. (Clicking on the wrench icon for each individual style doesn’t give the option to delete them either.)

Is there something here I don’t understand? Shouldn’t I be able to delete all of these styles under this circumstance? If so, how?


Here is my site Read-Only: https://preview.webflow.com/preview/nymm-2?utm_source=nymm-2&preview=3def8ecb6e85abad358ae527eff5aee2

hello @Chuck_Braman,

I see your frustration, but my advice to you would be to go back to your dashboard and delete that project from there. If you do it from there you will have to start a new project, but that is what you wanted right?

Hi @Pablo_Cortes,

Thanks for your advice.

Yes, that would sidestep the issue. But since the issue came up, I was curious if it’s a bug in Webflow, or alternatively, some lack of knowledge on my part that’s involved. Another motive is to learn Webflow, so when something happens that doesn’t make sense, I like to try to figure it out.

I guess this is a little troubling to me too: shouldn’t Webflow have the ability to delete all unused styles?

(My preference for duplicating the project was to duplicate the assets and color swatches. Admittedly, it would be not much work at all to re-add and re-create those if I started from scratch.)

In your read-only after deleting all content from all pages I was able to clean all styles without issues.

Thank you, @dram

This is embarrassing, but I had picked this project up after not working on it for a while, and had completely forgotten that I had more than one page—I remembered it as just having the home page.

I apologize for having unnecessarily wasted your time, I should have poked around a bit more before posting the “problem,” it just didn’t occur to me in this instance to look for more pages because I had assumed I only had one.

1 Like

Ah, good to know there is no such a glaring bug though!

1 Like

Hmm, maybe it is a bug. I have a project and i am 99% sure i deleted all content, but still there are classes in the style manager, that i can not delete:

https://preview.webflow.com/preview/whatisitwiththoseleftoverstyles?utm_source=whatisitwiththoseleftoverstyles&preview=cf323a5a3f2cf86798e83f9afb05fe1a

And in the original project with content there are many unused classes i can not delete as well.

That is really strange. I can’t find any content at all either.

Definitely looks like a bug in this case. Contacting support for direct intervention is the best way to proceed.

I had the same issue and figured out that the classes had an interaction associated to them. Once I removed the interactions I was able to delete the styles.

2 Likes