Streaming live at 10am (PST)

Can't figure out how to go to SSL on current website

Solved: I neglected to delete the www IP address before adding the cname, so that cleared that up and didn’t delete the other older @ IP addresses. So it now connects and I’ll see if I’m secure here shortly.
(the problem was…) I have a webflow hosted website and need to switch to SSL. I flipped the SSL switch on, then added the two A records recommended in webflows instructions with the new ip addresses in my hosting tab page. but when I check status it fails (after two hours of waiting). I also get a message I need to add a CNAME but my dns only has a cryptic cname entry setting where I have to enter and “alias” and a “other host” and this doesn’t match the instructions of entering a type (cname), name (www) and value (proxy…) What am I doing wrong?