Streaming live at 10am (PST)

Cant get "Focussed" state to change


#1

As you can see, this blue "Wall Lights" link is on the focussed state. I have changed it repeatedly but the changes are not taking effect. I would like the focussed state it to simply have the underline visible on the hover state.

I imagine its a "class" issue but as somewhat of a noob still, I'm having trouble.I don't want to effect any other change son other elements throughout the website.

Thanks much.


#2

Can you please share your project’s public link so it's easier to understand your issue?

Learn how to do it here: http://help.webflow.com/sharing-your-public-webflow-site-link

(Also @sabanna I ping you here because I'm leaving and won't have time to check this issue for several days so if you have some time to look it up when the public link comes, that'd be great.)


#3

Got it wink
@sethregan, does your navigation inside-page, or it is links to different pages?


#4

Oh heck... i copied the preview URL but forgot to paste it. smile
https://preview.webflow.com/preview/clf-test?preview=b1b52f26a272eac4ac3f7862c91df34e


#5

These top links , Wall Lights, Chandeliers, etc. navigate to different pages through the website. Thanks.


#6

Ok.
That state that you call "Focused" for links in webflow shows like "CURRENT". You can see it when page, that linked to you nav button, is currently opened in the screen view.

So just go to the page that you link should open and change settings on that nav button wink
Done smile

Just note: That Focused state works for Form fields blush, not for links.

Good luck,
Anna


#7

This doesnt get rid of the blue color... I tried changing the "Focussed" state on the Wall Lights page and it keeps reverting back to the blue.


#8

You can see that I am in the Focussed state, showing all classes associated, also that the Focussed color should be the brown, as is selected, yet it still remains blue when I preview the site.

Ive tried to effect the correction in other classes, including Nav Button "Focussed" and it just wont remove this blue.


#9
  1. Remove box-shadow on regular state (choose not current links)

  2. Forget about that Focused state, it is not for links, it is for Form Fields. So remove all that changes. (choose not current link) So you will no Focused state on links.

3.Choose current link and make changes: text-color, border-radius, inner shadow, whatever you wanted more.

To me everything works


#10

Hey it seems that it is the current state giving you trouble. Other users have had the same problem. Even though the color looks like it is inheriting the right color from the normal state it is not. Specifically declare the color you want on the current class.

@sabanna I think the focused state is very useful to use on links for people who use their keyboards to navigate websites. wink


#11

Maybe, I am sorry if I am wrong.
It just never been working for me. pensive


#12

Turn that frown upside down. In preview mode or in the published version. Click the "tab" key; this will cycle through your sites links and will activate any focused attributes. smile


#13

Im sorry but there is no box shadow on the regular state.


#14

It's cool.... i managed to figure it out based on your input regardless. Thank very much smile


#15

There is no shadow, but it is active (text looks blue). It keeps Focused state active too.


#16

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.