Streaming live at 10am (PST)

Can't link to CMS page from regular text link in the settings panel


#1

Hi,

I can't link to a CMS page from the settings panel of a text link which seems odd because I can link from the same page to a CMS page if I insert a Rich Text Block and link from there. Is this a bug or why can I not link using the text link?

Thanks in advance for any help!

Diarmuid


#2

Hi @Diarmuid_Sexton, if the link is nested inside of a dynamic list placed on a static page, it should allow you to link to the CMS detail page for the current dynamic item. I may not understand completely how you are using the link.

If you need to link to a dynamic page from a link outside of a dynamic list, then you would need to put in the path to the url using the external link type in link settings to link to the dynamic article by url path.

If you could provide a little more info how you are using the text link, it will help, perhaps a read-only link: http://help.webflow.com/faq/how-do-i-share-my-sites-read-only-link

The Rich Text may already be bound, but I would have to take a peek at the current settings. If it is easier for you, feel free to contact support@webflow.com.

Thanks in advance!


#3

Thanks for the response. I have got it working.

It's just strange that the link settings for a link block / text link (the "D" panel) and the link settings for a linked piece of text in any rich text block (the rtb pop-up when highlighted) are the very same - external, page, anchor, email, phone - except that the page link in the RTB allows the user to link to all dynamic pages.

It seems that this should be the case for links in the "D" settings panel also.


#4

Hi @Diarmuid_Sexton, great point! I am going to play around with it and help get this tested and those differences identified..

If you notice any other behavior, let me know. Thanks again!


#5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.