Streaming live at 10am (PST)

Can't paste "­" into a text element anymore


#1

Not sure if this is a bug or if webflow purposely deactivated this. But since last week or so, it’s not possibly anymore to paste the html code “­” into a headline or paragraph element.

This was the best way to solve the problem when a long headline is going out of the viewport of a mobile device and a senseful hyphenation was needed. This is especially important for german websites, which my work consists mostly of.

It would be great to know if others have noticed the same or don’t have a problem with this at all and can still paste these code bits.


#3

Hi @dennis

Thanks for posting about this. I spoke with the team some more and we don’t have support this functionality at the moment.

We’ve recently updated how the Webflow Designer handles text and content editing. It looks like characters like ­ were previously able to be used in our old Rich Text by happenstance rather than by design, but the new update doesn’t have this same functionality.

I’ve filed an internal enhancement request to get this added to our new content editor as a feature though, so hopefully you will be able to resume using this sort of shy-tag soon.

I’ll be sure to post back here as soon as I have an update.


#4

Hi Brando! Please do everything you can! This is a very important feature to handle text for responsive design, especially in Germany with our very long words. We love long words. It’s a kind of hobby and passion in Germany to create long words. So, please please fix it asap!

Greetz
Leidgeplagter Hoffnungsbewahrer


#5

Hey @Brando,

Thanks a lot for looking into this and filing an internal request!

It would be great if we could get this small feature added to webflow again soon. This sadly is quite a hinderance for us german webdesigners if we can’t use the ­ tag.
Words like “Datenverarbeitungsvorgänge” or “Ausbildungsverhältnissverträge” are killing us in large headlines.

If I noticed some weird behavior with the text element, where would be the best place to message you guys about it? Should I open a new bug thread here in the forums?


#6

Hi @dennis

This sadly is quite a hinderance for us german web designers

I can definitely understand this frustration and will be sure to pass along this urgency to the team.

In regards to the text element behavior – feel free to reach out to us with an official bug report: https://university.webflow.com/contact

Please provide as much information as possible — browser version, detailed description, and any screenshots are very helpful. :bowing_man:


#7

Done, thanks @Brando.


#8

Hi there,

As Brando mentioned, we’ve recently updated how the Webflow Designer handles text and content editing. Characters like the soft hyphen were previously able to be used in our old Rich Text by happenstance rather than by design, but the new update doesn’t have this same functionality.

However, there is a small workaround. With the most recent update, a soft hyphen can be added by pasting in the following where you would like the soft hyphen to occur (the soft hyphen is nested between the brackets):
[­]

Then, delete the brackets that are around the soft hyphen

I was able to test the above solution at the following tutorial URLs:
Live site - http://webflow-soft-hyphen.webflow.io/
Read-only link - https://preview.webflow.com/preview/webflow-soft-hyphen?preview=fb29367a40817b89799fa9e95073d3ae

If you are unsure of the steps, feel free to click on the link at the bottom of the page to view a tutorial video


#9

Hey @mistercreate,

Thanks for the tip with the workaround. I actually didn’t yet think of just copying an already placed ­ tag from my own project.
And thanks as well for creating this small page (even with a video!) where we can copy the &shy tag from!


#10

Glad I could help! :bowing_man:


#11

@mistercreate Great! Many thanks! For us German designers a soft hyphen is really necessary.

It is a bit more complicated then pasting the code snippet. Is this the final solution or will there be another handling or native solution in the future?


#12

Excellent question!

We have provided this solution/issue to the Team, and they are also looking into the enhancement.

You are not alone in thinking this would be an awesome feature to have in Webflow. It is definitely something you can vote for on our Webflow Wishlist

Voting for the enhancement would be extremely helpful!


#14

Well. I would LOVE to have the Soft Hyphens Back.
Not only Germany struggles with insanely long words.

Switzerland and Austria too.

Or if the CSS Hyphen would be a Standard to include in a CSS Class would be nice too.
Thanks a lot!


#15

But @dennis: Another Solution!

  1. Go to the Project Settings / Custom Code and Insert this CSS Hyphen snippet (maybe without !important;) :wink: into your Head Code. Change the .yourcssclassname into your Class names or Classes (separated by comma) .h1, .h2, .h3
<style>
.yourcssclassname
 {
  word-break: break-word !important;
  -webkit-hyphens: auto !important;
  -moz-hyphens: auto !important;
  -ms-hyphens: auto !important;
  -o-hyphens: auto !important;
  hyphens: auto !important;
}

</style>
  1. Set the Language of your Website to «de» for German. Just under the Head Code in the Project Settings.

  2. Publish the Site again. :):sunny:


#16

Hey @prohaska,

Yeah, that is a good solution too. Probably really useful for people in need of this and stumbling on this thread.

I personally don’t like using this for my headlines and text, since this way hyphens every syllable if required. I find this can make a text visually quite unpleasant to look at, because it can generate a lot of hyphenated words in a longer text.

But still thanks for pointing it out : )