Streaming live at 10am (PST)

Changes made to the Navbar Symbol is not reflecting on other pages

#1

Hi all!

After buying this template, I changed the menu button texts and positions in the Navbar symbol and moved the logo to the left. When I opened an another page, the Navbar symbol is still showing as the original position. The changes I have made to the menu button text are reflected, but not the positions. The Logo, for instance, is still showing in the middle. See the screenshots below.

Also, on any other page besides the main page, the drop down menu under the Activities button is acting weird on hover-off action. I couldn’t understand why this is happening.

Can you help me?
Read only link

This is the positioning I set on the main page:

This is how it still looks like the original position on another page:

0 Likes

#2

change the “wrapper” flex alignment as shown on the pic below

32

1 Like

#3

Thank you very much @shokoaviv . In order to understand the logic behind it, wasn’t all the Nav Symbol instances on all pages supposed to behave exactly like the one I adjusted on the main page? Why is it necessary to make this adjustment?

Will also appreciate if you can see the other issue: “Also, on any other page besides the main page, the drop down menu under the Activities button is acting weird on hover-off action. I couldn’t understand why this is happening.”

0 Likes

#4

Hi Malik,

It happens because you modify the style not for the logo link block itself, but only for “Current” state of it. Here is how you can fix that: https://www.useloom.com/share/52ec0dfd54d14227b179bb1ae33bf5e8

You can learn more about states from Webflow University: https://university.webflow.com/article/states

I hope it helps.

Feel free to contact us directly by email if you have more questions.

2 Likes

#5

Thank you for the quick response. @elasticthemes

Could you also review the interaction of the “Activities” hover drop down? It works smooth on the main page, but it is not smooth on rest of the pages.

I am asking here (instead of through e-mail) so anyone else having the same issue can benefit from it. Thank you

0 Likes

#6

Not sure about the reasons of that behaviour, maybe some kind of bug… But if you set up the interaction “Dropdown Open”/“Dropdown Close” on one of inner pages it works perfectly for the others: https://www.useloom.com/share/64d2052977aa4facb6f4776a2b28dc3c

1 Like

#7

Thank you for the quick and great support @elasticthemes

0 Likes

#8

We’re always glad to help!

0 Likes