Streaming live at 10am (PST)

Changing color of Rich Text Field by Collection setting not working


#1

Can't seem to simply change the color of the text in a rich text field. Don't know why a simple thing is so hard!
All of the items dealing with this in the forum are "closed" and the steps to fix it are not visible in the forum.
Have set the text color to use the value stored in the collection's field for text color, but nothing works.

Just want the text to be white. This is on the Chinese language page . . .


Help is appreciated.

Thanks!


Here is my public share link: https://preview.webflow.com/preview/irms-theme-park-design?preview=552411b6dc1c96a451d69148d8897195 [Revised]

(how to access public share link)


#2

Hi @IRMS,

Your share link is broken can you please re-edit ?
Thanks,


#3

Hi There--I revised my share link. THANKS!!


#4

Hi @IRMS,

"translated text" is a dynamic rich text element. This has nothing to do with "collection setting".

To edit the styles, first you have to go to settings and uncheck the link.

Then now you can select each item inside the rich text element, nest the selector within the "translated text".

Then you will be able to change the colour for each item. Do the same for each item.

After changing the styles, you can link back the original collection field.


#5

Thanks for your reply, but the "+ Nest selector inside of translated text" doesn't appear when I do it. What am I doing wrong? I just want the translated text to be white...


#6

did you do this first? Could you do a video recording of what you are trying to do?


#7

Yes I did...but the same option doesn't appear in my Designer interface.

There is no "+ Nest selector inside of translated text" when I add the "All Paragraphs" style. I don't want to turn all paragraphs on my entire website white, just the ones in the data field of this collection showing up on a grey background. I don't have a screen recording software--I can download one for a Mac if you tell me the name.

THANKS!


#8

Previously there was a class "translated text" on the rich text block when I took that screenshot. Could you add that back?


#9

I am slowly getting the hang of it . . . it's taking me a while, but appreciate your help. It's starting to work!! It's a bit complicated, but it's working . . .

[ UPDATE -- got it working! Thanks @samliew ]