Streaming live at 10am (PST)

Checklist input not working


#1

Hey. I have set up this form on our website, but it doesn't return in the webflow form if it is was selected or not. Instead of false or true, that part just stays blank.

Anyone know what the deal is?


#2

@finlayconn thanks so much for reaching out!

I'm not entirely sure what behavior you're seeing on your end but the checkbox option looks to be working on your site? Maybe I'm missing something though. Typically a checked or unchecked box returns a True or a False value respectively within a form.

Could you please update your post with some more information so we can help you faster? Things like your read-only link & screenshots really helps us to help you faster :slight_smile:

How to share a read-only link:

Thanks in advance!


#3

Hey CoLo Team!

That does seem odd so I looked into the website, but I was able to make it work.

Also I got a Form Submission on email:

All data are also being parsed properly on the form on your site:

I suspect you're using some kind of integration (Zapier?) that capture your data and send them somewhere else. Is that the case? Let us know and we'll try to help you further! :slight_smile:


#4

Ok now I see where the problem is.

The Guest Form in your Webflow settings still has "old" field name called Checkbox

Which you have changed to Brand Ambassador

So... Since the new field is actually being sent back in request when viewing a Form tab in Site Dashboard

And the current Form in Site Dashboard doesn't have that field there, it's simply not matching "Checkbox" !== "Brand Ambassador and leaves you with empty field.


Now what you can do about it... Two options (I recommend second one):

  1. You can change the form name

  2. ... or you can delete all form entries in Dashboard as that should reset how the form looks like (hence the Brand Ambassador field should be there)


Let us know if that works for you! :slight_smile:


#5

Thank you to the two of you for answering the question. @bart you deserve a pay rise. That was the greatest answer ever!


#6

Thanks, I'll forward! :smiley:

Let us know if you need any assistance :wink: Feel free to also hit us up at support@webflow.com :slight_smile:


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.