Streaming live at 10am (PST)

Child elements inherit from parent element?


#1

I seem to have some problems with the child elements (heading tags and text) inheriting css font color from the parent element (link block). It appears these elements already have css applied to them when dragging them onto the canvas...something that I must have accidentally done when first learning Webflow. If I clear that out, will the child element inherit the parent element style? If so, how do I clear it out?

Any help would be greatly appreciated my UX in regard to this has been commented on several times...would love to stop hearing the constructive criticism on this issue and look more professional, like maybe I know what the heck I'm doing :wink:

Best,

Nathan


#2

Hey @nathanphilsteele!

It sounds like you are using class names that already have css applied to them? If so, Webflow has an awesome clean up feature that allows you to remove previously styled classes that are no long being used.

If you want the child elements to inherit the parent elements' style, remove that child's class and use the clean up feature!

I'm not sure if this is what you meant, I hope it helps though! Let me know! :smile:

Cheers!


#3

Hi @Hamilton,

I think I have styles attached to "All H2 Headings" that I don't know how to clear. I did what you showed, which is really good to know, but it clear the drop shadow, for instance, that is shown when I drag an H1 on the canvas and I have to clear off. I just don't know how to reset those back to no styling.

Thanks @Hamilton,

Nathan


#4

@nathanphilsteele you can remove the global style from an element by dropping in a global element (like an H2), then going to the selector panel under the style tab, and selecting the Global style as shown in the gif below and then removing styles:


#5

Exactly what I was needing! Works like a charm!

https://www.flowglobemedia.com/

Thanks @Waldo !

Nathan


#6

What's funny is that I wanted to get those working like this months ago, so you helped me crack a 6 month issue, at least!

Thanks again @Waldo

Nathan


#7

For future reference


#8

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.