Streaming live at 10am (PST)

Clicking outside of open dropdown on mobile does not close it


#1

Hey there!

A few days ago I included a drop-down toggle on my website. It works perfectly on a desktop. But when I click outside the drop-down menu on tablets and mobile (I tested it on an Ipad, Safari and iPhone, Safari), it doesn’t disappear. Do anyone know how to solve this problem?

Thanks in advance!

Here is my site Read-Only: https://preview.webflow.com/preview/failory?preview=0c28d7f32070dc4609bae23b4cfcb23e


Dropdown doesn't disappear when clicking outside
#2

Hey there!

A few days ago I included a drop-down toggle on my website. It works perfectly on a desktop. But when I click outside the drop-down menu on tablets and mobile (I tested it on an Ipad, Safari and iPhone, Safari), it doesn’t disappear. Do anyone know how to solve this problem?

Thanks in advanced!


Here is my site Read-Only: LINK


#3

Hi @loantusitevol

Can you please let me know on which page is the dropdown located so we can troubleshoot the issue?

Thanks


#4

Hi Anna,

Yes, sorry, I forgot to add that information. The drop-down is on the homepage, which is called “Failory”.


#6

HI @loantusitevol

Thanks for sharing that additional information. I was able to see the issue with your site and can also reproduce it on my end.

I’ve filed a report with the team and we will start looking into solutions for this issue.

I’ll post back here when I have more information.


#7

Thanks Brando! Awesome customer service :wink:


#8

Brando,

The problem is still affecting my website. I tested it on iPhone 7, Safari and when I clicked outside the drop-down menu, the menu still appeared. Have you disocvered what can be happening?


#9

@loantusitevol

We are still looking into this guy, but hoping to have a solution for it soon.

I’ll keep you updated and let you know as soon as a fix is found.

Thanks for your patience!


#10

Hi @loantusitevol

Thanks again for posting about this issue.

Our team was able to find and push a fix for this. :tada:

Can you please refresh your designer and test this on your end?

​Thanks again for your help and patience!


#11

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.