Streaming live at 10am (PST)

Client having issues in Editor on their Webflow site


#1

This is directly from a client:

I’ve been having a really difficult time trying to input the job descriptions on the site. When I copy and paste sections into the body of the editor, it changes the formatting and there is no toolbar for me to edit formatting. When I finally copied and pasted several times and thought I had everything correct, I published it and logged out of webflow to look at my changes and the job description was blank. Can you please take a look and see if there is an easier way to go about inputting JDs? I’ve attached the one I was trying to input if you want to play around with it.

The editor does not appear to be robust. I have also been facing issues directly in the CMS (notably - not being able to add infinitely nested bullets “Really need this!”)

Also, there’s no code formatting option. In the CMS, there’s no heading options, there’s limited text formatting in general…

Any ideas on improving this?


#2

@cjroe Thanks for posting this, this definitely sounds like odd behavior. Formatting changes definitely can occur as the text will need to be reformatted after it’s added within the Webflow site.

I recommend writing out the posts within a Google doc and using heading tags within Google docs as copying and pasting from that workflow is much smoother in my experience.

The styles within a Rich Text Element will come directly from the styles defined by the Designer: https://university.webflow.com/article/rich-text

We’re definitely working on updates to improve and make the CMS more robust. If any options are missing, please be sure to add those to our Wishlist or vote for existing feature requests for the CMS.

Have you had a chance to read through this blog post on introducing your client to the Webflow CMS Editor to help them stay successful and running smoothly: https://webflow.com/blog/meet-the-clients-guide-to-the-webflow-editor

What sites are you seeing this issue occur in? When did it start occurring? Can you send me the site Read-Only links please? Is there any custom code on your site?

Please send me screenshots of the behavior you’re describing.

Can you please try the following:
(1) Try to reproduce the error while being logged into Webflow using Incognito mode with browser extensions turned off: https://support.google.com/chrome/answer/95464?hl=en
(2) If the problem persists, please take a screenshot of your Console and send it to me: https://developer.chrome.com/devtools/docs/console


#3

I agree with this client that the editor has severe limitations. One cannot easily update the content and it’s hard to add nested bullets, links, etc. The editor is just not robust. Can you please look into updating the controls to give it more functionality and less issues with snapping/glitching/not saving changes?


#4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.