Streaming live at 10am (PST)

CMS Buttons Not Linking Where I Want Them To

Hello Everyone,

I’m using a template to design my UX portfolio on Webflow and I’m having trouble with some of the links in the CMS. When I click the “see this project” button it takes me to a project showcase in the cms, when I want it to go to a page I made for each case study. I tried changing the link setting to link to a page, and that worked but it applied to all of the buttons. Then I tried making a subclass for each of the buttons but that had no effect.

Also, I’m trying to change the color of the hover states in the navbar but can’t find where those setting are.

Thanks so much!


Here is my site Read-Only: LINK

1 Like

Hey Landry!
Welcome :slight_smile:

Select the button “see this project” and go to the settings tab and see the link settings.

Change to the purple tab (indicating the collection) and select current project!

image

You will only have to do this once, each item will copy that setting!

Let me know if this works for you!

Hello!

The problem is I’m trying to have the buttons link to something thats not in the collections page, I’m trying to have 2 of the buttons link to either the identity force case study page or the saber metrics case study page. Thanks!

Sure!
Create two switch field inside your collection, one for each custom link.
Name them accordingly, then add two buttons into the cms element on the page and set the links to the pages. Set a conditional visibility filter with the condition of the switch checked state.
Now your two special items will have two buttons, so give the first button on them also a filter for each special item (two filters) for example on the name and give them axactly the names of the two special items

Thank you! I was able to set the conditional visibility filter and the buttons seem to be working. I kind of lost you when you describe setting a filter for each special item. Also, do you know how I would get the images to link accordingly as well? Thanks again!