Streaming live at 10am (PST)

CMS Changes not showing in published site

Hi there,

I’m having an issue when updating published CMS items. The changes made to existing CMS items are not showing in the published site. When editing a published CMS item and publishing the changes are not reflected in the published site. I have noticed that I have to publish the entire site for the changes to be available in the published site. This is the first time I’m facing this issue and don’t understand the reason behind.

Here is a video:

Also my public shared link:
https://preview.webflow.com/preview/brickdebt?utm_medium=preview_link&utm_source=designer&utm_content=brickdebt&preview=ba4cf197906a65bb1f6dca1c126c5d7b&pageId=5fd8abf10052d96f6e745fe3&itemId=5ffcb32ffe2b3b2e463ae1e9&mode=preview

Thanks for your help.

Ruben

Hey Rubens

Try opening the webflow Editor tool and make the changes there. I think they will update directly then. (Like if a client was using the site) However when changing the CMS-Items in the designer like you are doing now. You always have to publish the site for the changes to take effect.

Is there a specific reason why you want the CMS Changes to show on the live site without you having to press publish?

Felix

Thank you @felix_hellstrom for your reply. Unfortunately that doesn’t work either. I’m using forms to update the CMS items through Zapier. I’m not sure if it might be the fact that the field is inserted in a form …

AH okay then you will probably have to find a different way of updating the site with zapier. I know you can live update webflow sites with Zapier. I would take a closer look at the webflow api and zapier documentation.

https://developers.webflow.com/

https://platform.zapier.com/docs/zapier-intro

Thanks Felix for your response. I don’t think the problem is with Zapier as when I update the fields in CMS directly the changes are not populated in the published site in any case. The problem might be with Webflow.