Streaming live at 10am (PST)

CMS Collection item trigger won't open CMS modal

I’m trying to come up with and effective work around for CMS collection feature of my website. Currently, I have a team member section where in desktop, on hover, a short bio flies in and overlays the image. If people want to read the team member’s full bio they can click on the image and a modal pops up.

As there is no hover condition in Tablet and mobile I’m making it so the initial click on the picture begins the fly in interaction and over lay. Then I’m adding link in the element, which is only visible on Tablet and mobile, to serve as a button that when clicked opens up the modal. However, when I set up that link to use the ‘Open Team Member Modal’ interaction, it doesn’t work. It does the interaction of the parent element and has the overlay and fly in information fly back how. But if I change the interaction so that the link opens a different modal from a different section of the website (I did this to test what would happen) it then opens the modal as it’s supposed to.

Why does the interaction I’m trying to use in the CMS Collection not work for the CMS collection modal that I created but it does work for a modal that is not connected to the collection list and is instead part of another section?


Here is my public share link: https://preview.webflow.com/preview/athletic-outcomes?utm_medium=preview_link&utm_source=designer&utm_content=athletic-outcomes&preview=994941f9418a40ed141ad770a5350396&pageId=5e28a1d5a3c9cb40fe2b5305&mode=preview
(how to access public share link)

Here is the public share link. Not sure why it didn’t work before

https://preview.webflow.com/preview/athletic-outcomes?utm_medium=preview_link&utm_source=designer&utm_content=athletic-outcomes&preview=994941f9418a40ed141ad770a5350396&pageId=5e28a1d5a3c9cb40fe2b5305&mode=preview