Streaming live at 10am (PST)

CMS Custom code breaks reference units in <custom html> block


#1

CMS custom code is breaking injection points, it needs to say {{{imagesourceURL}}}and escape that back into the code on export.
In the actual export this field must say {{{imagesourceUrl}}}

The exported code removes this reference and only leaves one open bracket. :frowning:

  1. Larevel grabs the cms page and injects the image URL into the 'Active Subscriptions: Product Image URL"
  2. Same with Alt Image
  3. Webflow project is synced to Larevel project.
  4. Current work around must manually recode it and all other cms injections on custom html every time click Publish. NOT IDEAL
  5. Injection works on text blocks, paragraph blocks, text link blocks, and rich text blocks as intended.
  6. Injection fails on CUSTOM HTML CODE.

In above illustration code ‘<‘img src=’>’ needs to say ={{{imagesourceUrl}}} on code export and publish AND then it it will say https://cdn.com/url-path/image.png (on published live version).

In above illistration cms is configured correctly as intended.
These injections work on text blocks, link text blocks, paragraph blocks, and rich text blocks.
The injection break on CUSTOM HTML block.


#2

Does anyone have a oslution to keeping bracket integrity on CMS?


#3

Have you tried putting the brackets in the custom code and only the values inside of the bracket in the CMS item? Have you tried without using dynamic data at all, just to see if it breaks the same?


#4

@vincent

  1. Text block {{{ $value->header }}} works as intended
    1b. CMS -> Text block {{{ $value->header }}} works as intended

  2. Rich text block {{{ $value->header }}} works as intended
    2b. CMS -> Rich text block {{{ $value->header }}} works as intended

  3. Header block {{{ $value->header }}} works as intended
    3b. CMS -> Header block {{{ $value->header }}} works as intended

  4. Paragraph block {{{ $value->header }}} works as intended
    4b. CMS -> Paragraph block {{{ $value->header }}} works as intended

  5. HTML Embed code {{{ $value->header }}} works as intended

!! 6. CMS > HTML Embed Code {{{ $value->header }}} does not work as intended and renders only as ‘}’ after clicking on ‘Publish’.

image

image


closed #5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.