Streaming live at 10am (PST)

CMS Display limits disappeared on collection list settings

Recently I encountered the problem that in the collection list setting suddenly the selection box to “Paginate items” under Display Limits has disappeared.

I don’t know exactly how this happened and it hasn’t bothered me before. With other collection list wrappers there is nothing wrong and the setting: “Paginate items” does show normally.

Maybe it is because the products are in a Multi-reference field?

All help is welcome.

CMS Setting removed:


CMS Setting appears:

Pagination options don’t appear when all the items are displayed in the list.

Hi Vincent and thank you for your reply.

Let’s say 3 of the total 12 products need to be displayed, then I should have 4 pages total and should be able to set the paginate settings. This option currently does not appear, even when I set the limit to 4.

Any clue?

Mind sharing your read only link?

Of course, check it out here:

https://preview.webflow.com/preview/top-pvc?utm_medium=preview_link&utm_source=designer&utm_content=top-pvc&preview=90b25bbe9c254ab0c90eeb8f859c4430&pageId=609bafd54cd597789a9f485c&itemId=609bb1c9d55fe444228184c2&mode=preview

Thanks, yes you’re right from the beginning, this is not an option for collections lists sporting data from a multi-ref field.

Maybe because when nested into another list, the mutli-ref field is anyway limited to 5 items, with no pagination. This has to be for efficiency…

Normally here you’d have a products list instead, filtered on a category.

Sorry that I can’t provide a solution here.

After some further research, it seems that pagination doesn’t work for multi-ref fields.

Solution: Create a CMS collection containing all products and set a condition for the selected category that it is attached to (in my case).